Pages

Saturday, December 26, 2015

My packages with an 'outdated' package style

'Lucas Nussbaum' posted a message to the debian-devel mailing list about "Packages with /outdated/ packaging style" where one of my packages are listed.  Reference also:

  • https://lists.debian.org/debian-devel/2015/12/msg00383.html
  • http://www.lucas-nussbaum.net/blog/?p=904

The associated blog post  for the post as well as an older blog post on the same issue

  • http://www.lucas-nussbaum.net/blog/?p=891
  • https://www.lucas-nussbaum.net/blog/?p=751


Running the command noted in the post found that my 'postnews' package is listed:
$ ssh alioth.debian.org 'grep -A 2 Clay ~lucas/qa-20151226/*ddlist'
/srv/home/users/lucas/qa-20151226/merged.ddlist:Robert James Clay <jame@rocasa.us>
/srv/home/users/lucas/qa-20151226/merged.ddlist-   postnews
/srv/home/users/lucas/qa-20151226/merged.ddlist-
--
/srv/home/users/lucas/qa-20151226/qa-helper_classic_debhelper.txt.ddlist:Robert James Clay <jame@rocasa.us>
/srv/home/users/lucas/qa-20151226/qa-helper_classic_debhelper.txt.ddlist-   postnews
/srv/home/users/lucas/qa-20151226/qa-helper_classic_debhelper.txt.ddlist-

A comment by Lucas to the earlier blog post clarifies that, noting the following:
Lucas says:
March 4, 2013 at 4:12 pm
@Marcus: by “dh”, I mean “debhelper7″, or “the dh command”. “debhelper”
is “old-style debhelper packaging, with dh_* commands”

I haven't explicitly created a tickit for it but it is already on my TODO list, to have debian/rules use the dh command instead of using the 'dh_*' commands like it is currently.  Plan to make that change with the next upload, which will likely be which package the next upstream version.