Pages

Monday, June 12, 2017

Packaging Plack::Builder::Conditionals for Debian

  I had been working on updating the dependencies  for the LedgerSMB package in Debian which I am in the process of transitioning to the 1.5.x series and also the ledgersmb-1.5 package and it seems I missed that there is still a Perl module required for it that is not yet packaged for Debian:  Plack::Builder::Conditionals.  (At least, I hadn't yet been able to find it in Debian.)

  Working on taking care of that, I created the ITP (Intend To Package) Debian bug to track it: #863454

I was able to get the initial package completed but some issues were found with it. I corrected all of those and it was then uploaded to the Debian New queue.  It was then accepted into unstable as the package libplack-builder-conditionals-perl.  It was also then made available at the LedgerSMB Ubuntu PPA as well as will be made available at the apt.ledgersmb.org package repository as necessary.

No comments:

Post a Comment