Pages

Tuesday, June 19, 2018

LedgerSMB v1.6 Perl module dependencies

As Eric noted in IRC on 6 May 2018, there are five modules required for the new LedgerSMB version 1.6 that are not available in Debian v9 ("Stretch"), two of which seem not to be in Debian at all.  And then I found two others that one of them depends on and both were not in Debian.

  • Version::Compare  -  ITP 901638
  • HTML::Escape  -  ITP 901739
  • Module::Build::Pluggable::PPPort - Required for HTML::Escape.  ITP 901898
  • Module::Build::Pluggable - Required for Module::Build::Pluggable::PPPort.  ITP .901882
  • Plack::Request::WithEncoding - ITP 901756
  • PGObject::Util::DBAdmin -  Now that the newer version has been uploaded to CPAN, the debian package can be updated. (then backported later), 
  • Plack::Builder::Conditionals -  In buster|sid|artful|bionic|cosmic. so presumably just needs to be backported to stretch-backports
  • PGObject::Simple - In buster|sid|xenial|artful|bionic|cosmic. So presumably the newer version just needs to be backported to stretch-backports

Packaging Version::Compare for Debian

One of the new requirements for the new LedgerSMB v1.6.x series releases is the Perl module Version::Compare. I checked and found that it was not already in Debian, Created an ITP for it and completed the packaging, which was then uploaded and accepted into Debian Unstable.

Also found that an updated version of Version::Compare, 0.15.0, is in the code repository at
 https://github.com/dominikschulz/Version-Compare but is not showing as available at the metacpan site. I understand that before the cpan.org site went off line,  that newer version was there, but metacpan only had 0.14.0 and that is all that  is there now.  Opened bugs for that issue:

https://rt.cpan.org/Ticket/Display.html?id=125609
https://github.com/dominikschulz/Version-Compare/issues/3